Browse Source

Makefile: Update minimum dtc version to 1.4.3

With support for overlays and calling the -@ flag to dtc we need to have
at least 1.4.3 available now.

Cc: Simon Glass <sjg@chromium.org>
Reported-by: Stephen Warren <swarren@wwwdotorg.org>
Signed-off-by: Tom Rini <trini@konsulko.com>
master
Tom Rini 3 years ago
parent
commit
2fa73e784d
2 changed files with 6 additions and 5 deletions
  1. +2
    -2
      Makefile
  2. +4
    -3
      scripts/dtc-version.sh

+ 2
- 2
Makefile View File

@@ -1448,8 +1448,8 @@ System.map: u-boot
@$(call SYSTEM_MAP,$<) > $@

checkdtc:
@if test $(call dtc-version) -lt 0104; then \
echo '*** Your dtc is too old, please upgrade to dtc 1.4 or newer'; \
@if test $(call dtc-version) -lt 010403; then \
echo '*** Your dtc is too old, please upgrade to dtc 1.4.3 or newer'; \
false; \
fi



+ 4
- 3
scripts/dtc-version.sh View File

@@ -2,8 +2,8 @@
#
# dtc-version dtc-command
#
# Prints the dtc version of `dtc-command' in a canonical 4-digit form
# such as `0222' for binutils 2.22
# Prints the dtc version of `dtc-command' in a canonical 6-digit form
# such as `010404' for dtc 1.4.4
#

dtc="$*"
@@ -16,5 +16,6 @@ fi

MAJOR=$($dtc -v | head -1 | awk '{print $NF}' | cut -d . -f 1)
MINOR=$($dtc -v | head -1 | awk '{print $NF}' | cut -d . -f 2)
PATCH=$($dtc -v | head -1 | awk '{print $NF}' | cut -d . -f 3 | cut -d - -f 1)

printf "%02d%02d\\n" $MAJOR $MINOR
printf "%02d%02d%02d\\n" $MAJOR $MINOR $PATCH

Loading…
Cancel
Save